Add version ranges to dependencies; fixes #4513
authorIan Lynagh <igloo@earth.li>
Sun, 21 Nov 2010 15:12:16 +0000 (15:12 +0000)
committerIan Lynagh <igloo@earth.li>
Sun, 21 Nov 2010 15:12:16 +0000 (15:12 +0000)
haskell98.cabal

index 1506a4f..87938f2 100644 (file)
@@ -17,9 +17,14 @@ build-type:     Simple
 Cabal-Version: >= 1.6
 
 Library
-    build-depends:     base >= 3 && < 5,
-                    directory, random, old-time, old-locale, process,
-                    array, time
+    build-depends:     base        >= 3   && < 5,
+                    directory   >= 1.1 && < 1.2,
+                    random      >= 1.0 && < 1.1,
+                    old-time    >= 1.0 && < 1.1,
+                    old-locale  >= 1.0 && < 1.1,
+                    process     >= 1.0 && < 1.1,
+                    array       >= 0.3 && < 0.4,
+                    time        >= 1.2 && < 1.3
     exposed-modules:
         -- Haskell 98 (Prelude and Numeric are in the base package)
         Array, CPUTime, Char, Complex, Directory, IO, Ix, List, Locale,