Bump version to 1.0.1.1
[packages/haskell98.git] / haskell98.cabal
1 name:           haskell98
2 version:        1.0.1.1
3 license:        BSD3
4 license-file:   LICENSE
5 maintainer:     libraries@haskell.org
6 bug-reports: http://hackage.haskell.org/trac/ghc/newticket?component=libraries/haskell98
7 synopsis:       Compatibility with Haskell 98
8 description:
9         This package provides compatibility with the modules of Haskell
10         98 and the FFI addendum, by means of wrappers around modules from
11         the base package (which in many cases have additional features).
12         However Prelude, Numeric and Foreign are provided directly by
13         the base package.
14 homepage:       http://www.haskell.org/definition/
15 build-type:     Simple
16 Cabal-Version: >= 1.6
17
18 Library
19     build-depends:      base >= 3 && < 5,
20                     directory, random, old-time, old-locale, process, array
21     exposed-modules:
22         -- Haskell 98 (Prelude and Numeric are in the base package)
23         Array, CPUTime, Char, Complex, Directory, IO, Ix, List, Locale,
24         Maybe, Monad, Random, Ratio, System, Time,
25         -- FFI addendum (Foreign is in the base package)
26         Bits, CError, CForeign, CString, CTypes, ForeignPtr, Int,
27         MarshalAlloc, MarshalArray, MarshalError, MarshalUtils, Ptr,
28         StablePtr, Storable, Word
29     -- We need to set the package name to haskell98 (without a version number)
30     -- as it's magic.
31     ghc-options: -package-name haskell98
32
33 source-repository head
34     type:     darcs
35     location: http://darcs.haskell.org/packages/haskell98/
36