Merge pull request #82 from nmattia/document-concurrent-hput
[packages/bytestring.git] / .travis.yml
1 env:
2  - GHCVER=7.0.4 CABALVER=1.16
3  # we have to use CABALVER=1.16 for GHC<7.6 as well, as there's
4  # no package for earlier cabal versions in the PPA
5  - GHCVER=7.2.2 CABALVER=1.16
6  - GHCVER=7.4.2 CABALVER=1.16
7  - GHCVER=7.6.3 CABALVER=1.16
8  - GHCVER=7.8.2 CABALVER=1.18
9  - GHCVER=7.8.3 CABALVER=1.18
10  - GHCVER=8.0.1 CABALVER=1.24
11  - GHCVER=head  CABALVER=1.24
12
13 matrix:
14   allow_failures:
15    - env: GHCVER=head  CABALVER=1.24
16
17 before_install:
18  - travis_retry sudo add-apt-repository -y ppa:hvr/ghc
19  - travis_retry sudo apt-get update
20  - travis_retry sudo apt-get install cabal-install-$CABALVER ghc-$GHCVER
21  - export PATH=/opt/ghc/$GHCVER/bin:/opt/cabal/$CABALVER/bin:$PATH
22  - cabal --version
23
24 install:
25  - travis_retry cabal update
26  # can't use "cabal install --only-dependencies --enable-tests" due to dep-cycle
27  - cabal install "QuickCheck >=2.4" "byteorder ==1.0.*" "dlist >=0.5 && <0.8" "mtl >=2.0 && <2.3" deepseq test-framework-hunit test-framework-quickcheck2
28
29 script:
30  - cabal configure --enable-tests -v2
31  - cabal build
32  # --show-details=streaming is available for CABALVER>=1.20 only
33  - if [ "$(echo -e "1.20\n$CABALVER" | sort -rV | head -n1)" = "$CABALVER" ]; then
34      cabal test --show-details=streaming;
35    else
36      cabal test --show-details=always;
37    fi
38  - cabal sdist
39  # "cabal check" disabled due to -O2 warning
40  - export SRC_TGZ=$(cabal info . | awk '{print $2 ".tar.gz";exit}') ;
41    cd dist/;
42    if [ -f "$SRC_TGZ" ]; then
43       cabal install --force-reinstalls "$SRC_TGZ";
44    else
45       echo "expected '$SRC_TGZ' not found";
46       exit 1;
47    fi
48