Bump version to 0.10.10.0 and update changelog
[packages/bytestring.git] / .travis.yml
1 env:
2  - GHCVER=7.0.4 CABALVER=1.16
3  # we have to use CABALVER=1.16 for GHC<7.6 as well, as there's
4  # no package for earlier cabal versions in the PPA
5  - GHCVER=7.2.2 CABALVER=1.16
6  - GHCVER=7.4.2 CABALVER=1.16
7  - GHCVER=7.6.3 CABALVER=1.16
8  - GHCVER=7.8.4 CABALVER=1.18
9  - GHCVER=7.10.3 CABALVER=1.22
10  - GHCVER=8.0.2 CABALVER=1.24
11  - GHCVER=8.2.2 CABALVER=2.0
12  - GHCVER=8.4.4 CABALVER=2.2
13  - GHCVER=8.6.3 CABALVER=2.4
14  - GHCVER=8.8.1 CABALVER=2.4
15  - GHCVER=head  CABALVER=2.4
16
17 matrix:
18   allow_failures:
19    - env: GHCVER=head  CABALVER=2.4
20
21 before_install:
22  - travis_retry sudo add-apt-repository -y ppa:hvr/ghc
23  - travis_retry sudo apt-get update
24  - travis_retry sudo apt-get install cabal-install-$CABALVER ghc-$GHCVER
25  - export PATH=/opt/ghc/$GHCVER/bin:/opt/cabal/$CABALVER/bin:$PATH
26  - cabal --version
27
28 install:
29  - travis_retry cabal update
30  # can't use "cabal install --only-dependencies --enable-tests" due to dep-cycle
31  - cabal install
32       "QuickCheck >=2.10 && <2.14"
33       "byteorder ==1.0.*"
34       "dlist >=0.5 && <0.9"
35       "mtl >=2.0 && <2.3"
36       deepseq test-framework-hunit test-framework-quickcheck2
37
38 script:
39  - cabal configure --enable-tests -v2
40  - cabal build
41  # --show-details=streaming is available for CABALVER>=1.20 only
42  - if [ "$(echo -e "1.20\n$CABALVER" | sort -rV | head -n1)" = "$CABALVER" ]; then
43      cabal test --show-details=streaming;
44    else
45      travis_wait cabal test --show-details=always;
46    fi
47  - cabal sdist
48  # "cabal check" disabled due to -O2 warning
49  - export SRC_TGZ=$(cabal info . | awk '{print $2 ".tar.gz";exit}') ;
50    cd dist/;
51    if [ -f "$SRC_TGZ" ]; then
52       cabal install --force-reinstalls "$SRC_TGZ";
53    else
54       echo "expected '$SRC_TGZ' not found";
55       exit 1;
56    fi
57