[travis-ci] Bump to cabal-install-1.20 for GHC 7.8.4.
authorLennart Kolmodin <kolmodin@gmail.com>
Sat, 18 Feb 2017 10:42:08 +0000 (11:42 +0100)
committerLennart Kolmodin <kolmodin@gmail.com>
Sat, 18 Feb 2017 10:42:08 +0000 (11:42 +0100)
Again, trying to resolve haskell/cabal#4331.

.travis.yml

index cc51972..9ecf595 100644 (file)
@@ -10,8 +10,8 @@ matrix:
       addons: {apt: {packages: [cabal-install-1.18,ghc-7.4.2], sources: [hvr-ghc]}}
     - env: CABALVER=1.18 GHCVER=7.6.3
       addons: {apt: {packages: [cabal-install-1.18,ghc-7.6.3], sources: [hvr-ghc]}}
-    - env: CABALVER=1.18 GHCVER=7.8.4
-      addons: {apt: {packages: [cabal-install-1.18,ghc-7.8.4], sources: [hvr-ghc]}}
+    - env: CABALVER=1.20 GHCVER=7.8.4
+      addons: {apt: {packages: [cabal-install-1.20,ghc-7.8.4], sources: [hvr-ghc]}}
     - env: CABALVER=1.22 GHCVER=7.10.3
       addons: {apt: {packages: [cabal-install-1.22,ghc-7.10.3], sources: [hvr-ghc]}}
     - env: CABALVER=1.24 GHCVER=8.0.1
@@ -33,7 +33,7 @@ install:
  - cabal sandbox init
 # can't use "cabal install --only-dependencies --enable-tests --enable-benchmarks" due to dep-cycle.
 # must split in two separate 'cabal install's since cabal doesn't update the cabal library before it's needed in 'cabal-version' constraints.
- - cabal install "bytestring >= 0.10.4" 'Cabal == 1.24.*' -j1 -v2
+ - cabal install "bytestring >= 0.10.4" 'Cabal == 1.24.*' -j
  - cabal install criterion deepseq mtl "QuickCheck >= 2.8" HUnit "test-framework-quickcheck2 >= 0.3" "random >= 1.0.1.0" attoparsec cereal tar zlib -j
 
 script: