user-guide: Allow build with sphinx < 1.8