configure: Bump minimum bootstrap GHC version to 7.8