Update to (unreleased) `deepseq-1.4.0.0`