Update autoconf test for gcc to require 4.7 and up