Revert "The LLVM backend now only works with 2.9+, don't try it if we have 2.7"
authorDavid Terei <davidterei@gmail.com>
Tue, 17 Jan 2012 08:30:33 +0000 (00:30 -0800)
committerDavid Terei <davidterei@gmail.com>
Tue, 17 Jan 2012 08:30:33 +0000 (00:30 -0800)
This reverts commit 0114212f8588211d3dd6735d55127bce2cc1dad7.

testsuite/mk/test.mk

index dc49681..23c3495 100644 (file)
@@ -86,17 +86,11 @@ else
 RUNTEST_OPTS += -e ghc_with_smp=0
 endif
 
-LLVM_VERSION = $(shell $(SHELL) -c "llvmc --version | grep version | sed 's/^.*version \([0-9]*\)\.\([0-9]*\).*$$/\1\.\2/'" 2> /dev/null)
-
-ifneq "$(LLVM_VERSION)" ""
-ifneq "$(LLVM_VERSION)" "2.7"
+ifneq "$(shell $(SHELL) -c 'llvmc --version | grep version' 2> /dev/null)" ""
 RUNTEST_OPTS += -e ghc_with_llvm=1
 else
 RUNTEST_OPTS += -e ghc_with_llvm=0
 endif
-else
-RUNTEST_OPTS += -e ghc_with_llvm=0
-endif
 
 ifeq "$(WINDOWS)" "YES"
 RUNTEST_OPTS += -e windows=True