Don't try to use gcc-4.2 on XCode >= 4.2
authorIan Lynagh <igloo@earth.li>
Wed, 11 Jan 2012 19:01:55 +0000 (19:01 +0000)
committerIan Lynagh <igloo@earth.li>
Wed, 11 Jan 2012 19:02:55 +0000 (19:02 +0000)
It was removed in 4.2.

aclocal.m4

index c54918e..1c89e0d 100644 (file)
@@ -1989,10 +1989,12 @@ AC_DEFUN([XCODE_VERSION],[
 # Finds where gcc is
 AC_DEFUN([FIND_GCC],[
     if test "$TargetOS_CPP" = "darwin" &&
-        test "$XCodeVersion1" -ge 4
+       test "$XCodeVersion1" -eq 4 &&
+       test "$XCodeVersion2" -lt 2
     then
-        # From Xcode 4, use 'gcc-4.2' to force the use of the gcc legacy
-        # backend (instead of the LLVM backend)
+        # In Xcode 4.1, 'gcc-4.2' is the gcc legacy backend (rather
+        # than the LLVM backend). We prefer the legacy gcc, but in
+        # Xcode 4.2 'gcc-4.2' was removed.
         FP_ARG_WITH_PATH_GNU_PROG([CC], [gcc-4.2])
     else
         FP_ARG_WITH_PATH_GNU_PROG([CC], [gcc])