users-guide: Note change in LLVM support policy
authorBen Gamari <ben@smart-cactus.org>
Wed, 13 Apr 2016 11:41:09 +0000 (13:41 +0200)
committerBen Gamari <ben@smart-cactus.org>
Fri, 15 Apr 2016 14:24:45 +0000 (16:24 +0200)
docs/users_guide/8.0.1-notes.rst

index 2f011c4..dcbd104 100644 (file)
@@ -219,6 +219,11 @@ Language
 Compiler
 ~~~~~~~~
 
+-  The LLVM code generator now supports only LLVM 3.7. This is in contrast to our
+   previous policy where GHC would try to support a range of LLVM versions
+   concurrently. We hope that by supporting a narrower range of versions we can
+   provide more reliable support for each.
+
 -  Warnings can now be controlled with ``-W(no-)...`` flags in addition to
    the old ``-f(no-)warn...`` ones. This was done as the first part of a
    rewrite of the warning system to provide better control over warnings,