Switch to LLVM version 3.9
authorErik de Castro Lopo <erikd@mega-nerd.com>
Fri, 18 Nov 2016 08:14:42 +0000 (19:14 +1100)
committerErik de Castro Lopo <erikd@mega-nerd.com>
Fri, 18 Nov 2016 08:14:43 +0000 (19:14 +1100)
Test Plan:
Build and test on x86_64/linux (perf-llvm) and armhf/linux.

Reviewers: austin, hvr, bgamari

Reviewed By: bgamari

Subscribers: RyanGlScott, thomie

Differential Revision: https://phabricator.haskell.org/D2719

configure.ac

index 7a7e75b..0312aed 100644 (file)
@@ -551,7 +551,7 @@ esac
 # tools we are looking for. In the past, GHC supported a number of
 # versions of LLVM simultaneously, but that stopped working around
 # 3.5/3.6 release of LLVM.
-LlvmVersion=3.8
+LlvmVersion=3.9
 AC_SUBST([LlvmVersion])
 sUPPORTED_LLVM_VERSION=$(echo \($LlvmVersion\) | sed 's/\./,/')
 AC_DEFINE_UNQUOTED([sUPPORTED_LLVM_VERSION], ${sUPPORTED_LLVM_VERSION}, [The supported LLVM version number])