Allow containers-0.6, QuickCheck-2.12 in Hadrian
authorRyan Scott <ryan.gl.scott@gmail.com>
Thu, 29 Nov 2018 23:46:16 +0000 (18:46 -0500)
committerRyan Scott <ryan.gl.scott@gmail.com>
Thu, 29 Nov 2018 23:46:22 +0000 (18:46 -0500)
Summary:
Currently, Hadrian has restrictive upper bounds on
`containers` and `QuickCheck` that prevents it from building with
the latest versions of each respective library (0.6.0.1 and
2.12.6.1). There doesn't appear to be any good reason to do so,
since Hadrian builds fine with them, so let's bump the upper version
bounds accordingly.

Test Plan: ./build/hadrian.sh

Reviewers: bgamari, alpmestan, snowleopard

Reviewed By: snowleopard

Subscribers: rwbarton, carter

Differential Revision: https://phabricator.haskell.org/D5389

hadrian/hadrian.cabal

index 422217b..7d54301 100644 (file)
@@ -115,12 +115,12 @@ executable hadrian
                        , TypeFamilies
     build-depends:       base                 >= 4.8     && < 5
                        , Cabal                >= 2.5     && < 2.6
-                       , containers           == 0.5.*
+                       , containers           >= 0.5     && < 0.7
                        , directory            >= 1.2     && < 1.4
                        , extra                >= 1.4.7
                        , mtl                  == 2.2.*
                        , parsec               >= 3.1     && < 3.2
-                       , QuickCheck           >= 2.6     && < 2.12
+                       , QuickCheck           >= 2.6     && < 2.13
                        , shake                >= 0.16.4
                        , transformers         >= 0.4     && < 0.6
                        , unordered-containers >= 0.2.1   && < 0.3