template-haskell: drop `TemplateHaskell` requirement
authorHerbert Valerio Riedel <hvr@gnu.org>
Tue, 17 Nov 2015 14:55:43 +0000 (15:55 +0100)
committerHerbert Valerio Riedel <hvr@gnu.org>
Tue, 17 Nov 2015 14:55:43 +0000 (15:55 +0100)
`other-extensions: TemplateHaskell` is inaccurate: It's not required
to compile `template-haskell` (otherwise we wouldn't be able to build
that package via `ghc-stage1`...)

This has been discovered while working on #11102

libraries/template-haskell/template-haskell.cabal

index 40debcb..d4dd81e 100644 (file)
@@ -32,7 +32,6 @@ Library
         PolymorphicComponents
         RankNTypes
         ScopedTypeVariables
-        TemplateHaskell
         UnboxedTuples
 
     exposed-modules: