Drop HAVE_containers_050 from bootstrap flags
authorBen Gamari <ben@smart-cactus.org>
Sat, 4 Mar 2017 21:04:37 +0000 (16:04 -0500)
committerBen Gamari <ben@smart-cactus.org>
Sat, 4 Mar 2017 21:04:37 +0000 (16:04 -0500)
Cabal now sets this itself if MIN_VERSION_containers isn't defined.

utils/ghc-cabal/ghc.mk

index b8f03a9..6250484 100644 (file)
@@ -54,7 +54,6 @@ $(ghc-cabal_DIST_BINARY): utils/ghc-cabal/Main.hs $(TOUCH_DEP) | $$(dir $$@)/. b
               -no-user-$(GHC_PACKAGE_DB_FLAG) \
               -Wall -fno-warn-unused-imports -fno-warn-warnings-deprecations \
               -DCABAL_VERSION=$(CABAL_VERSION) \
-              -DHAVE_containers_050 \
               -DBOOTSTRAPPING \
               -optP-include -optPutils/ghc-cabal/cabal_macros_boot.h \
               -odir  bootstrapping \