Remove -fno-warn-amp sledgehammers for validate
authorAustin Seipp <austin@well-typed.com>
Sun, 20 Apr 2014 06:00:44 +0000 (01:00 -0500)
committerAustin Seipp <austin@well-typed.com>
Sun, 20 Apr 2014 06:01:29 +0000 (01:01 -0500)
GHC should now fully compliant with respect to the Applicative Monad
proposal (including all upstream libraries), and does not need to
suppress this warning anymore.

Signed-off-by: Austin Seipp <austin@well-typed.com>
mk/validate-settings.mk

index 8797bf9..cac938d 100644 (file)
@@ -32,7 +32,6 @@ SRC_HC_OPTS     += $(WERROR) -Wall
 
 GhcStage1HcOpts += -fwarn-tabs
 GhcStage2HcOpts += -fwarn-tabs
-GhcStage2HcOpts += -fno-warn-amp # Temporary sledgehammer until we sync upstream.
 
 utils/hpc_dist-install_EXTRA_HC_OPTS += -fwarn-tabs
 
@@ -46,7 +45,6 @@ GhcStage2HcOpts += -O -dcore-lint
 # running of the tests, and faster building of the utils to be installed
 
 GhcLibHcOpts    += -O -dcore-lint
-GhcLibHcOpts    += -fno-warn-amp # Temporary sledgehammer until we sync upstream.
 
 # We define DefaultFastGhcLibWays in this style so that the value is
 # correct even if the user alters DYNAMIC_GHC_PROGRAMS.