Upgrade to the latest stack resolver
authorNeil Mitchell <ndmitchell@gmail.com>
Thu, 7 Feb 2019 14:50:47 +0000 (14:50 +0000)
committerMarge Bot <ben+marge-bot@smart-cactus.org>
Sat, 9 Feb 2019 17:22:30 +0000 (12:22 -0500)
hadrian/stack.yaml

index d379133..7f06944 100644 (file)
@@ -1,13 +1,12 @@
 # For more information, see: http://docs.haskellstack.org/en/stable/yaml_configuration.html
 
 # Specifies the GHC version and set of packages available (e.g., lts-3.5, nightly-2015-09-21, ghc-7.10.2)
-resolver: lts-12.10
+resolver: lts-13.6
 
 # Local packages, usually specified by relative directory name
 packages:
 - '.'
 - '../libraries/Cabal/Cabal'
-- '../libraries/text'
 
 # This is necessary to build until happy's version bounds are updated to work
 # with the new Cabal version.  Stack's error message explains the issue:
@@ -19,6 +18,10 @@ packages:
 # TODO: Remove this once it's no longer necessary
 allow-newer: true
 
+# shake-0.17.4 and below depend on heaps, which depends on a specific Cabal
+extra-deps:
+- shake-0.17.5
+
 nix:
    enable: false
    packages: