Ignore deprecation warnings for bitSize in libs when validating
authorIan Lynagh <ian@well-typed.com>
Sun, 23 Sep 2012 20:46:23 +0000 (21:46 +0100)
committerIan Lynagh <ian@well-typed.com>
Sun, 23 Sep 2012 20:46:23 +0000 (21:46 +0100)
mk/validate-settings.mk

index 08300b9..a94d2b6 100644 (file)
@@ -71,6 +71,12 @@ libraries/containers_dist-install_EXTRA_HC_OPTS += -fno-warn-pointless-pragmas
 # bytestring has identities at the moment
 libraries/bytestring_dist-install_EXTRA_HC_OPTS += -fno-warn-identities
 
+# bytestring uses bitSize at the moment
+libraries/bytestring_dist-install_EXTRA_HC_OPTS += -fno-warn-deprecations
+
+# containers uses bitSize at the moment
+libraries/containers_dist-install_EXTRA_HC_OPTS += -fno-warn-deprecations
+
 # Temporarily turn off unused-do-bind warnings for the time package
 libraries/time_dist-install_EXTRA_HC_OPTS += -fno-warn-unused-do-bind 
 # Temporary: mkTyCon is deprecated