Give a better error for uses of R11, R12, ...; trac #5422
authorIan Lynagh <igloo@earth.li>
Sun, 6 Nov 2011 15:53:39 +0000 (15:53 +0000)
committerIan Lynagh <igloo@earth.li>
Sun, 6 Nov 2011 15:53:39 +0000 (15:53 +0000)
commitab9e7e37baa71576f9dd8aaff07d10a330e5625d
tree8a472b8e4ac6c9b4075eadc1a1bee0730f4ead65
parent017897cff24a1eb24f0227806898b1aa738560d5
Give a better error for uses of R11, R12, ...; trac #5422

It's still a panic, as it wouldn't be trivial to give a proper error
at the point that we generate it, but it's now a bit nicer:
    Registers above R10 are not supported (tried to use R11)
compiler/codeGen/CgUtils.hs