configure: Set version to 8.7
[ghc.git] / libraries / libiserv / libiserv.cabal
1 Name: libiserv
2 Version: 8.7.1
3 Copyright: XXX
4 License: BSD3
5 License-File: LICENSE
6 Author: XXX
7 Maintainer: XXX
8 Synopsis: Provides shared functionality between iserv and iserv-proxy
9 Description:
10 Category: Development
11 build-type: Simple
12 cabal-version: >=1.10
13
14 Flag network
15     Description:   Build libiserv with over-the-network support
16     Default:       False
17
18 Library
19     Default-Language: Haskell2010
20     Hs-Source-Dirs: src
21     Exposed-Modules: Lib
22                    , GHCi.Utils
23     Build-Depends: base       >= 4   && < 5,
24                    binary     >= 0.7 && < 0.9,
25                    bytestring >= 0.10 && < 0.11,
26                    containers >= 0.5 && < 0.7,
27                    deepseq    >= 1.4 && < 1.5,
28                    ghci       == 8.7.*
29     if flag(network)
30        Exposed-Modules: Remote.Message
31                       , Remote.Slave
32        Build-Depends: network    >= 2.6 && < 2.7,
33                       directory  >= 1.3 && < 1.4,
34                       filepath   >= 1.4 && < 1.5
35
36     if os(windows)
37        Cpp-Options: -DWINDOWS
38    else
39        Build-Depends: unix   >= 2.7 && < 2.9