Factor out buildPackageGhciLibrary from buildPackageLibrary and make it more robust.
[ghc.git] / stack.yaml
1 # For more information, see: http://docs.haskellstack.org/en/stable/yaml_configuration.html
2
3 # Specifies the GHC version and set of packages available (e.g., lts-3.5, nightly-2015-09-21, ghc-7.10.2)
4 resolver: lts-5.1
5
6 # Local packages, usually specified by relative directory name
7 packages:
8 - '.'
9
10 # Packages to be pulled from upstream that are not in the resolver (e.g., acme-missiles-0.3)
11 extra-deps: []
12
13 # Override default flag values for local packages and extra-deps
14 flags: {}
15
16 # Extra package databases containing global packages
17 extra-package-dbs: []
18
19 # Control whether we use the GHC we find on the path
20 # system-ghc: false
21
22 # Require a specific version of stack, using version ranges
23 # require-stack-version: -any # Default
24 # require-stack-version: >= 1.0.0
25
26 # Override the architecture used by stack, especially useful on Windows
27 # arch: i386
28 # arch: x86_64
29
30 # Extra directories used by stack for building
31 # extra-include-dirs: [/path/to/dir]
32 # extra-lib-dirs: [/path/to/dir]
33
34 # Allow a newer minor version of GHC than the snapshot specifies
35 # compiler-check: newer-minor