Hadrian: simple targets for building libraries and executables
[ghc.git] / hadrian / stack.yaml
1 # For more information, see: http://docs.haskellstack.org/en/stable/yaml_configuration.html
2
3 # Specifies the GHC version and set of packages available (e.g., lts-3.5, nightly-2015-09-21, ghc-7.10.2)
4 resolver: lts-12.10
5
6 # Local packages, usually specified by relative directory name
7 packages:
8 - '.'
9 - '../libraries/Cabal/Cabal'
10 - '../libraries/text'
11
12 # This is necessary to build until happy's version bounds are updated to work
13 # with the new Cabal version.  Stack's error message explains the issue:
14 #
15 # In the dependencies for happy-1.19.9:
16 #    Cabal-2.3.0.0 from stack configuration does not match <2.2  (latest matching version is 2.0.1.1)
17 # needed due to hadrian-0.1.0.0 -> happy-1.19.9
18 #
19 # TODO: Remove this once it's no longer necessary
20 allow-newer: true
21
22 nix:
23    enable: false
24    packages:
25    - autoconf
26    - automake
27    - gcc
28    - git
29    - ncurses
30    - perl