Fix `base` lower version bounds for GHC 8.0 (it will be `4.8.2` at the least)
authorryan.gl.scott <ryan.gl.scott@gmail.com>
Sat, 10 Oct 2015 14:35:46 +0000 (14:35 +0000)
committerryan.gl.scott <ryan.gl.scott@gmail.com>
Sat, 10 Oct 2015 14:35:46 +0000 (14:35 +0000)
Control/Monad/Trans/Error.hs

index 899e08b..5243dd9 100644 (file)
@@ -5,7 +5,7 @@
 #if __GLASGOW_HASKELL__ >= 710
 {-# LANGUAGE AutoDeriveTypeable #-}
 #endif
-#if !(MIN_VERSION_base(4,8,3))
+#if !(MIN_VERSION_base(4,8,2))
 {-# OPTIONS_GHC -fno-warn-orphans #-}
 #endif
 -----------------------------------------------------------------------------
@@ -72,8 +72,8 @@ import Data.Monoid (mempty)
 import Data.Traversable (Traversable(traverse))
 import System.IO.Error
 
-#if !(MIN_VERSION_base(4,8,3))
--- These instances are in base-4.8.3
+#if !(MIN_VERSION_base(4,8,2))
+-- These instances are in base-4.8.2
 
 instance MonadPlus IO where
     mzero       = ioError (userError "mzero")