Refactor & modernize `.cabal` to `cabal-version>=1.10`