Fix GMP v4 compatibility.
[packages/integer-gmp.git] / integer-gmp.cabal
index ed1242f..817a854 100644 (file)
@@ -27,6 +27,7 @@ extra-source-files:
     cbits/float.c
     cbits/gmp-wrappers.cmm
     cbits/longlong.c
+    changelog.md
     config.guess
     config.sub
     configure
@@ -34,6 +35,7 @@ extra-source-files:
     gmp/config.mk.in
     install-sh
     integer-gmp.buildinfo.in
+    include/HsIntegerGmp.h.in
 
 extra-tmp-files:
     autom4te.cache
@@ -41,6 +43,7 @@ extra-tmp-files:
     config.status
     gmp/config.mk
     integer-gmp.buildinfo
+    include/HsIntegerGmp.h
 
 source-repository head
     type:     git
@@ -72,6 +75,7 @@ Library
         GHC.Integer.Type
 
     c-sources: cbits/cbits.c
+    include-dirs: include
 
     build-depends: ghc-prim >= 0.3.1 && < 0.4