Apply Safe Haskell flag for newer GHCs only.
authorbrk <ben@eschew.org>
Mon, 26 Dec 2016 14:16:52 +0000 (09:16 -0500)
committerGitHub <noreply@github.com>
Mon, 26 Dec 2016 14:16:52 +0000 (09:16 -0500)
Apparently with GHC 7.2.2 and Cabal 1.16, the Data.Set module is not marked as being Safe.

src/Compiler/Hoopl/Passes/Dominator.hs

index 1926cb1..7cd8b7e 100644 (file)
@@ -1,6 +1,6 @@
 {-# LANGUAGE CPP, GADTs #-}
 {-# OPTIONS_GHC -Wall -fno-warn-name-shadowing #-}
-#if __GLASGOW_HASKELL__ >= 701
+#if __GLASGOW_HASKELL__ >= 723
 {-# LANGUAGE Safe #-}
 #endif