Bump `base` constraint
authorHerbert Valerio Riedel <hvr@gnu.org>
Tue, 9 Sep 2014 15:08:27 +0000 (17:08 +0200)
committerHerbert Valerio Riedel <hvr@gnu.org>
Tue, 9 Sep 2014 15:08:27 +0000 (17:08 +0200)
...and update cabal meta-info while at it

changelog.md
hoopl.cabal

index deff9b2..234c993 100644 (file)
@@ -1,5 +1,9 @@
 # Changelog for [`hoopl` package](http://hackage.haskell.org/package/hoopl)
 
+## 3.10.0.2  *TBA*
+
+ - Add support for `base-4.8.0.0` package version
+
 ## 3.10.0.1  *Mar 2014*
 
   - Remove UTF8 character from hoopl.cabal to workaround issue
index d73b61c..d487d49 100644 (file)
@@ -1,13 +1,6 @@
 Name:                hoopl
-Version:             3.10.0.1
--- NOTE: Don't forget to update 'repository this' tag when incrementing version!
--- GHC 7.6.1 released with 3.9.0.0
--- version 3.8.6.0 is the version that goes with the camera-ready Haskell'10 paper
--- version 3.8.7.0 works with GHC 7
--- version 3.8.7.1 adds some unnamed functions without breaking compatibility
--- version 3.8.7.2 adds Compiler.Hoopl.Fuel.liftFuel
--- version 3.8.7.4 re-exports runWithFuel
--- version 3.9.0.0 adds the new API for working with blocks, and lots of internal refactoring
+Version:             3.10.0.2
+-- NOTE: Don't forget to update ./changelog.md
 Description:
   Higher-order optimization library
   .
@@ -31,11 +24,6 @@ Source-repository head
   Type:       git
   Location:   http://git.haskell.org/packages/hoopl.git
 
-Source-repository this
-  Type:       git
-  Location:   http://git.haskell.org/packages/hoopl.git
-  Tag:        hoopl-3.10.0.1-release
-
 Library
   Default-Language:  Haskell2010
   Other-Extensions:  CPP
@@ -52,7 +40,7 @@ Library
     Other-Extensions: Safe Trustworthy
 
   Hs-Source-Dirs:    src
-  Build-Depends:     base >= 4.3 && < 4.8, containers >= 0.4 && < 0.6
+  Build-Depends:     base >= 4.3 && < 4.9, containers >= 0.4 && < 0.6
   Exposed-Modules:   Compiler.Hoopl,
                      Compiler.Hoopl.Internals,
                      Compiler.Hoopl.Wrappers,