update to work with the latest parallel package