Remove the hack to use a patched Cabal submodule in CI (#650)
[hadrian.git] / stack.yaml
index 0d8809b..d506426 100644 (file)
@@ -1,36 +1,33 @@
 # For more information, see: http://docs.haskellstack.org/en/stable/yaml_configuration.html
 
 # Specifies the GHC version and set of packages available (e.g., lts-3.5, nightly-2015-09-21, ghc-7.10.2)
-resolver: lts-5.1
+resolver: lts-10.8
 
 # Local packages, usually specified by relative directory name
 packages:
 - '.'
+- '../libraries/Cabal/Cabal'
+- '../libraries/text'
 
-# Packages to be pulled from upstream that are not in the resolver (e.g., acme-missiles-0.3)
 extra-deps:
-- shake-0.15.6
-
-# Override default flag values for local packages and extra-deps
-flags: {}
-
-# Extra package databases containing global packages
-extra-package-dbs: []
-
-# Control whether we use the GHC we find on the path
-# system-ghc: false
-
-# Require a specific version of stack, using version ranges
-# require-stack-version: -any # Default
-# require-stack-version: >= 1.0.0
-
-# Override the architecture used by stack, especially useful on Windows
-# arch: i386
-# arch: x86_64
-
-# Extra directories used by stack for building
-# extra-include-dirs: [/path/to/dir]
-# extra-lib-dirs: [/path/to/dir]
-
-# Allow a newer minor version of GHC than the snapshot specifies
-# compiler-check: newer-minor
+- shake-0.16.1
+
+# This is necessary to build until happy's version bounds are updated to work
+# with the new Cabal version.  Stack's error message explains the issue:
+#
+# In the dependencies for happy-1.19.9:
+#    Cabal-2.3.0.0 from stack configuration does not match <2.2  (latest matching version is 2.0.1.1)
+# needed due to hadrian-0.1.0.0 -> happy-1.19.9
+#
+# TODO: Remove this once it's no longer necessary
+allow-newer: true
+
+nix:
+   enable: false
+   packages:
+   - autoconf
+   - automake
+   - gcc
+   - git
+   - ncurses
+   - perl