Fixes building with stack within recent versions of ghc repo (#646)
[hadrian.git] / stack.yaml
1 # For more information, see: http://docs.haskellstack.org/en/stable/yaml_configuration.html
2
3 # Specifies the GHC version and set of packages available (e.g., lts-3.5, nightly-2015-09-21, ghc-7.10.2)
4 resolver: lts-10.8
5
6 # Local packages, usually specified by relative directory name
7 packages:
8 - '.'
9 - '../libraries/Cabal/Cabal'
10 - '../libraries/text'
11
12 extra-deps:
13 - shake-0.16.1
14
15 # This is necessary to build until happy's version bounds are updated to work
16 # with the new Cabal version.  Stack's error message explains the issue:
17 #
18 # In the dependencies for happy-1.19.9:
19 #    Cabal-2.3.0.0 from stack configuration does not match <2.2  (latest matching version is 2.0.1.1)
20 # needed due to hadrian-0.1.0.0 -> happy-1.19.9
21 #
22 # TODO: Remove this once it's no longer necessary
23 allow-newer: true
24
25 nix:
26    enable: false
27    packages:
28    - autoconf
29    - automake
30    - gcc
31    - git
32    - ncurses
33    - perl