Update Cabal submodule to latest 1.22 snapshot