Update hpc submodule to 0.6.0.3 version