Update Cabal submodule to latest snapshot