Fix error message for './configure' regarding '--with-ghc' [skip ci]