Update libffi-tarballs submodule to libffi 3.1 (re #10238)