Accept the old -package-conf flags for backwards compatibility
authorSimon Marlow <marlowsd@gmail.com>
Tue, 22 May 2012 11:11:59 +0000 (12:11 +0100)
committerSimon Marlow <marlowsd@gmail.com>
Tue, 22 May 2012 11:42:58 +0000 (12:42 +0100)
compiler/main/DynFlags.hs

index c26efb2..31eb368 100644 (file)
@@ -1762,6 +1762,10 @@ package_flags = [
   , Flag "global-package-db"     (NoArg (addPkgConfRef GlobalPkgConf))
   , Flag "user-package-db"       (NoArg (addPkgConfRef UserPkgConf))
 
+    -- backwards compat with GHC<=7.4 :
+  , Flag "package-conf"          (HasArg (addPkgConfRef . PkgConfFile))
+  , Flag "no-user-package-conf"  (NoArg removeUserPkgConf)
+
   , Flag "package-name"          (hasArg setPackageName)
   , Flag "package-id"            (HasArg exposePackageId)
   , Flag "package"               (HasArg exposePackage)