SysTools: Add detection support for LLD linker
authorBen Gamari <ben@smart-cactus.org>
Sun, 21 Jan 2018 18:31:29 +0000 (13:31 -0500)
committerBen Gamari <ben@smart-cactus.org>
Sun, 21 Jan 2018 18:31:38 +0000 (13:31 -0500)
I noticed while trying to test against LLVM 5.0 that GHC would throw "Couldn't
figure out linker information" warnings due to LLD being chosen by configure.
Adding detection support to silence these is simple enough, let's just do it.

compiler/main/DynFlags.hs
compiler/main/SysTools/Info.hs

index 77837e6..05d1ec1 100644 (file)
@@ -5481,6 +5481,7 @@ isBmi2Enabled dflags = case platformArch (targetPlatform dflags) of
 data LinkerInfo
   = GnuLD    [Option]
   | GnuGold  [Option]
+  | LlvmLLD  [Option]
   | DarwinLD [Option]
   | SolarisLD [Option]
   | AixLD    [Option]
index e9dc685..6b31057 100644 (file)
@@ -96,6 +96,7 @@ https://gcc.gnu.org/onlinedocs/gcc-5.2.0/gcc.pdf :
 neededLinkArgs :: LinkerInfo -> [Option]
 neededLinkArgs (GnuLD o)     = o
 neededLinkArgs (GnuGold o)   = o
+neededLinkArgs (LlvmLLD o)   = o
 neededLinkArgs (DarwinLD o)  = o
 neededLinkArgs (SolarisLD o) = o
 neededLinkArgs (AixLD o)     = o
@@ -140,6 +141,9 @@ getLinkerInfo' dflags = do
           -- ELF specific flag, see Note [ELF needed shared libs]
           return (GnuGold [Option "-Wl,--no-as-needed"])
 
+        | any ("LLD" `isPrefixOf`) stdo =
+          return (LlvmLLD [])
+
          -- Unknown linker.
         | otherwise = fail "invalid --version output, or linker is unsupported"