Bump Cabal deps
[ghc.git] / libraries / bin-package-db / bin-package-db.cabal
1 name:           bin-package-db
2 version:        0.0.0.0
3 license:        BSD3
4 maintainer:     cvs-ghc@haskell.org
5 bug-reports:    glasgow-haskell-bugs@haskell.org
6 synopsis:       A binary format for the package database
7 cabal-version:  >=1.6
8 build-type: Simple
9
10 source-repository head
11     type:     darcs
12     location: http://darcs.haskell.org/ghc
13
14 flag base3
15     default: False
16
17 Library {
18     exposed-modules:
19             Distribution.InstalledPackageInfo.Binary
20
21     if flag(base3)
22         build-depends: base >= 3 && < 4
23         cpp-options: -DBASE3
24     else
25         build-depends: base >= 4 && < 5
26
27     build-depends: binary == 0.5.*,
28                    Cabal >= 1.8 && < 1.14
29
30     extensions: CPP
31 }