Update to a newer version of libffi