Require primitive >= 0.5.0.1