Require ghc >= 6.9