Require primitive >= 0.3.1