Require primitive >= 0.5.0.1
[darcs-mirrors/vector.git] / vector.cabal
index 18c903b..b9bdc08 100644 (file)
@@ -38,6 +38,10 @@ Description:
         .
         * <http://trac.haskell.org/vector>
         .
+        Changes in version 0.10.0.1
+        .
+        * Require @primitive@ to include workaround for a GHC array copying bug
+        .
         Changes in version 0.10
         .
        * @NFData@ instances
@@ -57,7 +61,8 @@ Extra-Source-Files:
       tests/Main.hs
       tests/Boilerplater.hs
       tests/Utilities.hs
-      tests/Tests/Stream.hs
+      tests/Tests/Move.hs
+      tests/Tests/Bundle.hs
       tests/Tests/Vector.hs
       benchmarks/vector-benchmarks.cabal
       benchmarks/LICENSE
@@ -98,9 +103,10 @@ Library
         Data.Vector.Internal.Check
 
         Data.Vector.Fusion.Util
-        Data.Vector.Fusion.Stream.Size
         Data.Vector.Fusion.Stream.Monadic
-        Data.Vector.Fusion.Stream
+        Data.Vector.Fusion.Bundle.Size
+        Data.Vector.Fusion.Bundle.Monadic
+        Data.Vector.Fusion.Bundle
 
         Data.Vector.Generic.Mutable.Base
         Data.Vector.Generic.Mutable
@@ -129,7 +135,7 @@ Library
         vector.h
 
   Build-Depends: base >= 4 && < 5
-               , primitive >= 0.5 && < 0.6
+               , primitive >= 0.5.0.1 && < 0.6
                , ghc-prim
                , deepseq >= 1.1 && < 1.4