Require ghc >= 6.9
[darcs-mirrors/vector.git] / vector.cabal
index 45fd9a4..e7c715c 100644 (file)
@@ -11,16 +11,19 @@ Cabal-Version:  >= 1.2
 Build-Type:     Simple
 
 Library
+  Extensions: CPP
   Exposed-Modules:
         Data.Vector.Stream.Size
         Data.Vector.Stream
 
+        Data.Vector.MVector
+        Data.Vector.MVector.Mut
+        Data.Vector.IVector
+
         Data.Vector.Unboxed.Unbox
-        Data.Vector.Unboxed.Prim
         Data.Vector.Unboxed.Mutable
         Data.Vector.Unboxed
 
-        Data.Vector.Prim
         Data.Vector.Mutable
         Data.Vector
   Include-Dirs:
@@ -29,5 +32,6 @@ Library
   Install-Includes:
         phases.h
 
-  Build-Depends: base, array, ghc-prim
+  Build-Depends: base, array, ghc-prim,
+                 ghc >= 6.9