Require primitive >= 0.5.0.1
[darcs-mirrors/vector.git] / vector.cabal
index 4cdb762..b9bdc08 100644 (file)
@@ -1,5 +1,5 @@
 Name:           vector
 Name:           vector
-Version:        0.10.9
+Version:        0.10
 License:        BSD3
 License-File:   LICENSE
 Author:         Roman Leshchinskiy <rl@cse.unsw.edu.au>
 License:        BSD3
 License-File:   LICENSE
 Author:         Roman Leshchinskiy <rl@cse.unsw.edu.au>
@@ -38,6 +38,10 @@ Description:
         .
         * <http://trac.haskell.org/vector>
         .
         .
         * <http://trac.haskell.org/vector>
         .
+        Changes in version 0.10.0.1
+        .
+        * Require @primitive@ to include workaround for a GHC array copying bug
+        .
         Changes in version 0.10
         .
        * @NFData@ instances
         Changes in version 0.10
         .
        * @NFData@ instances
@@ -99,6 +103,7 @@ Library
         Data.Vector.Internal.Check
 
         Data.Vector.Fusion.Util
         Data.Vector.Internal.Check
 
         Data.Vector.Fusion.Util
+        Data.Vector.Fusion.Stream.Monadic
         Data.Vector.Fusion.Bundle.Size
         Data.Vector.Fusion.Bundle.Monadic
         Data.Vector.Fusion.Bundle
         Data.Vector.Fusion.Bundle.Size
         Data.Vector.Fusion.Bundle.Monadic
         Data.Vector.Fusion.Bundle
@@ -130,7 +135,7 @@ Library
         vector.h
 
   Build-Depends: base >= 4 && < 5
         vector.h
 
   Build-Depends: base >= 4 && < 5
-               , primitive >= 0.5 && < 0.6
+               , primitive >= 0.5.0.1 && < 0.6
                , ghc-prim
                , deepseq >= 1.1 && < 1.4
 
                , ghc-prim
                , deepseq >= 1.1 && < 1.4